Jump to content
  • 0

Autoslew error at first start. DDM60



Hi everybody,


I recently bought an ASA DDM 60 never used from a reseller stock

first of all i tried to install Autoslew software . it was not easy to find where to download it but it is done now .

i decided to install autoslew on the telescope NUC who run on Windows 11 pro. At the installation , it was asked to install Dotnet35 . i did it. i went to windows features to add dotnet35 to my windows services. i also installed ASCOM 6.6 SP1 .

Then the installation software was launched again and i was able to install it . It asked me to install the prolific software , i said yes as the minipc was a new and clean . it said that the prolific dll was already present  ( ?!  but why not) . installation finished and autoslew icon appeared on my desktop .

i clicked on it . a small picture of a DDM60 appears . Then disappears and...nothing else . no prompt asking for the serial number, nothing.

i decided to check the prolific compatibility with windows 11 and i found a very recent and compatible driver , i installed it but nothing changed .

i'm unable to lauch the Autoslew software


Is someone kind enough to help me ?

Thanks a lot

PS : when i try to launch Astrooptik driver throught ascom device hub i got this error message :



Driver Initialization Error
The driver "AstrooptikServer.Telescope" threw an exception when loaded.


This means that the driver would not start properly.


Please screen print or use CTRL+C to copy all of this message and report it to the driver author with a request for assistance.


System.Runtime.InteropServices.COMException (0x800702E4): La récupération de la fabrique de classes COM pour le composant avec le CLSID {99352175-9A79-4457-BFE5-05BBBB61FB5C} a échoué en raison de l'erreur suivante : 800702e4 L’opération demandée nécessite une élévation. (Exception de HRESULT : 0x800702E4).

   à System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck)

   à System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)

   à System.RuntimeType.CreateInstanceDefaultCtor(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)

   à System.Activator.CreateInstance(Type type, Boolean nonPublic)

   à System.Activator.CreateInstance(Type type)

   à ASCOM.Utilities.ChooserForm.CmdProperties_Click(Object eventSender, EventArgs eventArgs) dans C:\ASCOM Build\Export\ASCOM.Utilities\ASCOM.Utilities\ChooserForm.vb:ligne 371


Edited by Patryn
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hi Patryn,

Firstly, does your DDM60 have incremental or absolute encoders?

You need to download the Autoslew Manual for the encoders your mount has fitted. If you follow the instructions carefully you should have no trouble.

If you have already done this, and are still in trouble your best course is to contact ASA Support and request a remote session with Wolfgang Promper.


Link to comment
Share on other sites

  • 0

Dear MarkS.


thanks a lot for your help . I believe that i have incremental encoder ( i didn't know that DDM 60 was available with Absolute encoders) .

However i solved my issue , i needed to change a regional settings in windows ( number separator shall be "." and not ",") .  I manage to run autoslew , and to connect to the mount and taking control of the mount with Autoslew, Nina and PRism . I think that i have understand that in the closed loop systeme , the dynamic constant ( in fact the mass )  shall be sufficient for a good PID settings .

she works like a charm . so i bought one more ddm60 pro and one DDM 85 from the same reseller stock . very low price . i'm happy . They will go to my Observatory when i will maybe rent piers with a DDM 60 already fitted on it .


i'm very pleased with this mount .

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...